O programu

Nápověda verze 1.0r.0.6 (01.09.2006)

Program byl vytvořen firmou Data Protect ve Visual FoxPro 8 CZ - SP1 .

Program používá knihovny pro komprimaci dat azip32.dll a aunzip32.dll, licencované naší firmou a jejich použití mimo program je nepřípustné.
Program také používá kryptovací knihovnu pro šifrování dat cryptpak.dll, která je veřejně přístupná.

Přečtěte si o změnách v jednotlivých modulech programu

Přečtěte si o základní informace o funkcích jednotlivých modulů programu

Jak program nainstalovat?

Jak program spustit?

K čemu je a jak využít program Socm_Adm.Exe?

Máte s programem problém ?


Dodavatel programu

Data Protect
P.O. Box 15
102 01 Praha 15 - Hostivař

Mgr. Jan Solař

E-mail:: info@dataprotect.cz, help@dataprotect.cz

Hotline: +420 222 95 22 75, +420 608 255 164

http: www.dataprotect.cz


Změny v programu

Seznam změn v programu

Změny jsou uvedeny chronologicky od nejnovější verze.
  • SocM 1.0 rel. 0.6a ze dne 01.09.2006
    • Modul SocM_R(interně 10.6.1.0)
      • Data je možno importovat kromě formátu dle
        • "Informace č.176 pro obce z 24.03.2003 Odboru informatizace veřejné správy MV ČR s Č.j:OIS-6-10/1-2003"
        také ve formátu dle
        • "Informace č.184 pro obce z 20.11.2003 Odboru informatizace veřejné správy MV ČR s Č.j:OIS-6-10/1-2003"
      • Data v RO je možno před novým importem úplně vyprázdnit, nebo při importu přidávat a měnit
  • SocM 1.0 rel. 0.4a ze dne 01.06.2004
    • Modul SocM_R(interně 10.4.1.0)
      • V Databázi ÚIR-Adr je možno mít data jak původní verze 4.1., tak i data s novou strukturou verze 4.2
  • SocM 1.0 rel. 0.3a ze dne 24.10.2003
    • Všechny moduly byly upraveny a překompilovány v prostředí Vfp 8 CZ SP1
    • Modul SocM (interně 10.3.1.0)
      • Upravena detekce jména stanic ve Windows 98 a Milenium
      • Upraven modul generování tisků i pro Word 97
      • Přidána makra pro oslovení v 5.pádu
      • Přidána externí sekce "Style" do "Head" v dokumentech HTML
    • Modul SocM_R(interně 10.3.1.0)
      • Upraveno dohledání písmen v orientačním čísle v ÚIR-ADR při inicializaci importu dat z Evidence obyvatel ČR
  • Konec výčtu změn
Poznámka: "(interně vv.rr.i.0)" vyjadřuje vypsanou verzi pomocí funkce "Vlastnosti souboru" daného Exe ve Windoows


Instalace programu

Důležité informace:
  • Zkontrolujte nejříve požadavky na hardware a software na každé stanici, kde bude program využíván
  • K běhu programu musíte nejdříve nainstalovat Podporu pro běh programu Vfp 8 na každé stanici, kde bude program využíván
  • K běhu programu musíte mít někde v síti naistalovánu MS databázi "Územně identifikační registr adres", která je k dispozici zdarma od Ministerstva práce a sociálních věcí.
    Všechny základní informace o ÚIR-ADR můžete získat na oficiální www stránce MPSV ČR ve vyznačeném odkazu :

1. Instalace vlastního programu v síti
  • Z www dodavatele překopírujte celý rozbalený adresář programu Socm "DataProt" do místa v síti, kde jej chcete mít umístěn, a zpřístupněte jej v síti tak, aby byl přístupný přes logické jméno disku (například P:\Ukázkový Pokusný Adresář\DataProt\...)
    Příklad, jak může potom datová oblast na disku vypadat:
  • Nastavte uživatelská práva přístupu
    • Vám i uživatelům do podadresář "Socm\" s právy Read, Write, Make & Remove Directory
    • Jen Vám (uživateli raději ne) do podadresář "Admin_8\", kde jsou podpůrné programy pro případy nouze a telefonního kontaktu s dodavatelem
2. Prvotní nastavení programu
  • Na Vaší stanici nainstalujte Podporu pro běh programu Vfp 8
  • V souboru "DataProt\Socm\Ini\Uir-Ini.Ini" upravte buď jen první řádek, nebo celou sekci
[MSSQL_UIRADR]
Uir_Adr_Sql_ODBC=Uir_User   --- Zadejte název zdroje dat ODBC
Uir_Adr_Sql_DB_Name=UIRADR  --- Zadejte název databáze ÚIR-ADR
Uir_Adr_Sql_User=PADR  --- Zadejte jméno pro připojení k databázi ÚIR-ADR
Uir_Adr_Sql_Passw=PADR  --- Zadejte heslo pro připojení k databázi ÚIR-ADR
Výše, modře vyznačené, údaje by měly být standardní, včetně toho,
       že by databáze měla být jen R/O
3. První spuštění programu na dané stanici (i v síti)
  • Dále postupujte podle Podrobného návodu pro 1. spuštění programu!


Spuštění programu na stanici

1. Spusťte indexační program "SocMInde.Exe"

Objeví se obrazovka, kde budete vyzváni, abyste přiřadili k dané stanici jednoznačné označení stanice čísle (1 až 99) v síti:

Doporučujeme administrátorům programu přiřadit si "šikovné" číslo, třeba 1, ostatní přiřazovat uživatelům
Jednoznačné označení stanice je svázáno s konfigurací a poté je možno pouštět hlavní program "SocM.Exe" bez parametrů

Pokud se Vám dále zobrazí některá z následujících obrazovek, napravte problém s kontaktováním SQL databáze ÚIR-ADR dle textu chyby :

Pokud indexační program SocM skončí v pořádku, pokračujte dále:

2. Spusťte hlavní program "SocM.Exe" bez parametru

Objeví se upozornění, že pro danou stanici byl založen nový konfigurační soubor, například:

Protože je spuštěna Demo verze programu bez licence, při úplně prvním spuštění programu Socm v síti se objeví obrazovka, kde budete vyzváni k výběru působnosti Vašeho úřadu.
Upozornění: Oblasti jsou nabídnuty dle abecedy (v pořadí Kraje, Okresy, Města)
  • KÚ si vyberou svoji působnost hned na začátku výběru (z nabídky "Kraj: ...")
  • MÚ si vyberou svoji působnost až dole výběru (z nabídky "ORP: ...")
  • Dávejte v případě MÚ pozor, abyste nevybrali působnost okresu, ale správně jen ORP Vašeho města
Ukázka výběru:

Protože je spuštěna Demo verze programu bez licence, při úplně prvním spuštění programu Socm v síti zobrazí se Vám upozornění:

Přihlašte se do programu jako Administrátor, implicitní heslo Administrátora bylo registrovaným uživatelům zasláno e-mailem, pokud nejste registrováni nebo jste e-mail nedostali (případně smazali), kontaktujte dodavatele programu, rádi Vám heslo sdělíme.

Pozor: Při každém startu program detekuje verzi a datum aktualizace dat v ÚIR-Adr a případně o neaktualizovaných datech v ÚIR-ADR vypíše varování

Po úplně prvním spuštění programu Socm v síti
  • Zadejte v systémových parametrech uživatele na první záložce adresu Vašeho úřadu
  • Načtěte licenci na 4.záložce v systémových parametrech progmamu, samozřejmě jen tehdy, pokud máte program licencován a máte od dodavatele licenční soubor *.SocM
Po prvním spuštění programu Socm na stanici nezapomeňte upravit konfiguraci dané stanice

Také nezapomeňte, i když to můžete udělat i později:
  • Upravit číselník hesel
  • Upravit číselník názvů stanic
  • Naimportovat data z registru obyvatel MÚ

V případě nesrozumitelností, nejasností nebo problémů prosím kontaktujte dodavatele programu !


Požadavky na Hw a Sw

Typ | OS | RAM | OS | RAM | OS | RAM | OS | RAM
Minimální | Win 98 | 8 MB*) | Win NT | 16 MB*) | Win 2000 | 16 MB*) | Win XP | 128 MB**)
Doporučená | Win 98 | 32 MB | Win NT | 64 MB | Win 2000 | 64 MB | Win XP | 512 MB
Vysvětlivky:

*) Pracuje s odkládacím souborem (swap)
**) Ale to spíš chtějí Windows XP a Microsoft Office, než naše programy.

Důležité poznámky:
  • Programy pracují jen v rozlišení 800x600 a vyšším.
  • Doporučeno nastavení alespoň 256 barev, ale programy pracují i se 16 barvami.
  • Funkce programů ověřeny jak v síti Windows, tak i ve Windows nad sítí Novell.
  • Funkce programů ověřeny při současném spuštění síťové verze z různých typů Windows, pouze musí být ve Windows každé stanice doinstalována podpora knihovnami dll.
  • Programy pracují také na terminálu "Windows NT Server 4.0, Terminal Server Edition")
Microsoft, Windows, Win32, Windows 98, Windows NT, Windows 2000 a Windows XP jsou buď registrovanými ochrannými známkami nebo ochrannými známkami firmy Microsoft ve Spojených státech amerických a dalších zemích.


Verze a release programu

Aktuální verzi a release programu zjistíte
z hlavní nabídky programu volbou "Nápověda" - "O Programu".

Pomocí tlačítek "Uživatel programu" a "Podrobnosti o programu" i další informace (počet licencí, interní release programu a jiné).


Knihovna dll pro komprimaci dat

Komprimační knihovny azip32.dll a aunzip32.dll jsou využívány ke komprimaci dat při archivaci souborů. Vytvořené soubory typu ZIP jsou kompatobilní se standardními soubory, vytvořenými jinými programy, jako například PkZip.

Knihovny jsou po instalaci umístěny v systémovém adresáři Windows dané stanice a dodavatel programu má licenci na jejich využití ve svých programech.

Uživatel programu nesmí tyto knihovny používat mino program !


Knihovna dll pro šifrování dat

Knihovna CryptPak.Dll je využívána k šifrování dat (hlavně celého registru obyvatel) při načítání a ukládání dat.

Knihovna je po instalaci umístěna v systémovém adresáři Windows dané stanice včetně podpůrného souboru Blowfish.ucx, obsahujícím velmi účinné (standard DES převyšující) "BlowFish" kryptovací a dekryptovací algoritmy včetné výpočtů SHA1, MD5 a CRC32.

Citlivá data v registru obyvalel jsou kryptována s minimálně 64bitovým klíčem.
Díky laskavosti pánů Dr. Milana Kosiny a Markuse Hahna je možno knihovnu používat mino program !
Podrobnější informace získáte u dodavatel programu.


Zaslání e-mailu

Tato akce nastane v následujících případech:
  • Při běhu programu vznikne kritická chyba
  • Pokud to vyžaduje některá funkce programu
Pole nemůžete na obrazovce opravovat, ale pokud zvolíte akci tlačítkem [image],
nedojde k odeslání e-mailu okamžitě, ale bude spuštěn Váš poštovní program pro zpracování pošty a Vy můžete
  • data před odesláním e-mailu upravit
  • nebo neodeslat e-mail vůbec
    • .
Poznámky:
  • povolení akce nastavuje administrátor programu v konfiguraci stanice , implicitně je zakázáno
  • doporučuje mít odesílání povoleno a odesílat e-mail - je to nejrychlejší metoda, jak se my dozvíme, že máte problémy s programem
  • při akci odeslání e-mailu nejsou naší firmě předávána žádná jiná data z Vaší počítačové sítě, než jsou uvedena na obrazovce
 Příklad pro odeslání chyby při běhu programu:
V níže uvedené ukázce je stav po chybě, která byla způsobena výpadkem síťových disků a program nemohl načíst soubor:


Adresa z ÚIR-ADR

Nejdříve naplňte adresu: Kdykoliv stisknete tlačítko "Adresa z ÚIR-ADR",
objeví se obslužná obrazovka pro nalezení adresy

Pokud nenaleznete domovní nebo orientační číslo, pravděpodobně ještě nebylo adresní místo do ÚIR-ADR vloženo.

V tom případě vyberte adresu ze stejné ulice nebo části obce s jiným libovolným domovním nebo orientačním číslem, uložte a potom stisknete tlačítko "Náhradní adresa z ÚIR-ADR".
Objeví se obslužná obrazovka pro zadání náhradní adresy

Pokud je v ÚIR-ADR nalezeno více adresních míst dle zadaných kritérií,
Objeví se obslužná obrazovka pro bližší specifikaci adresy

Podrobnější popis je přímo v odkazech výše u ukázek výše uvedených obrazovek.


Centrální adresář osob

Popis modulu Z1 - Centrální obsluha adresáře osob

  • vkládání a oprava údajů o občanech do programu
  • vyhledání občanů dle RČ či příjmení a jména v registru obyvatel včetně automatického doplnění adresy z registru; zjištění rozdílů adres v evidenci a v registru obyvatel a případná aktualizace adres včetně tisku přehledů (seznam položek nenalezených v registru obyvatel, seznam položek s rozdílnou adresou v registru obyvatel apod.); podmínkou pro vstup do registru obyvatel je umožnění importu dat administrátorem počítačové sítě z aktuálního registru obyvatel MÚ nebo z uživatelského souboru Dbf.
  • úprava adres trvalého, přechodného a skutečného místa pobytu z Územně identifikačního registru ČR (ÚIR-ADR)
  • "svázání" občanů do společně bydlících skupin a společně posuzovaných osob
  • evidování příjmů jednotlivých občanů
  • evidování dalších potřebných údajů o občanech dle různých oblastí evidence
  • základní tisky různých rekapitulací
  • přidávání, povolování a úprava vzorů pro generování rozhodnutí, dopisů a textů
  • generování základních typů rozhodnutí, dopisů a textů
  • centrální evidence všech generovaných rozhodnutí, dopisů a textů
  • generování elektronických dotazů do SSP a zpracování odpovědí
  • generování elektronických dotazů na ÚP a zpracování odpovědí
  • všechny tisky rozhodnutí, dopisů a textů jsou archivovány na disku pro budoucí opakovaný tisk a jejich vydání je zapisováno do seznamu tisků v základní evidenci
  • tisk údajů, nutných pro statistické výkazy
  • centrální vytváření souborů dat pro proplácení možných dávek a příspěvků (disketa složenek "B" s průvodkou, zakryptované soubory složenek "B" pro přenos České poště, soubory, tisky pro převod bankovní operací včetně elektronických výstupů do banky, seznam plateb pokladnou s výčetkou platidel)
  • tisk případného platebního dokladu pro vyplacení příspěvku hotově pokladnou
  • centrální zaúčtování vratek z diskety od České pošty; podmínkou je nadstandardní předávání dat z České pošty na disketě místo tištěným dokladem, tisk neproplacených plateb včetně důvodu neproplacení, proplacených plateb s datumem a místem proplacení a pod.
  • centrální účetní evidence vyplacených dávek a příspěvků a zpracováných vratek včetně tisku potřebných rekapitulací
  • základní uživatelská konfigurace programu (životní minima, adresní a bankovní údaje uživatele programu, cenové sazby ČP, základní sazby pro proplácení dle zákonů a vyhlášek)


Evidence invalidních občanů

Popis modulu Ei - Evidence invalidních občanů

  • evidence žadatelů a držitelů výhod a invalidních průkazů a dalších informací o invalidních občanech (data lékařských kontrol, informace o zákonných zástupcích a podobně), včetně informací z historie (evidují se všechny průkazy včetně čísel a typů, které invalidní občan kdykoliv měl)
  • tisk různých přehledů a seznamů (např. občané s daným průkazem a daným typem postižení ke dni, občané se zákonným zástupcem, občané s kontrolou od-do a mnoho jiných)
  • evidence vozidel včetně držitele vozidla a dalších údajů (SPZ, typ, popis vozidla, číslo TP, typ ukončení platnosti a pod.), včetně informací z historie (evidují se všechna držená vozidla, která invalidní občan, zákonný zástupce či žadatel příspěvku na provoz vozidla měl); tisk různých přehledů, seznamů (např. držitelé vozidel ke dne, seznam vydaných dálničních nálepek, seznam občanů k vydání nálepky atd.)
  • evidence vydávaných tabulek (01 a 02 dle metodiky Ministerstva dopravy) do vozidel včetně tisku rekapitulace vydaných tabulek
  • evidence a tisk nových průkazů (speciální tiskárna) od 1.7.2000 včetně tisku a evidence příjmových dokladů buď kompletně nebo za jednotlivé pokladny dle stanic v síti
  • tisk složenek AV pro platbu za vystavení průkazů a evidence zaplacený složenek
  • zajištění automatizovaného výpočtu ročních (z historie i pololetních) dávek na provoz motor. vozidel a navýšení dle ujetých km, zpracování nedoplatků a platby doplatků (např. v průběhu pololetí ukončen provoz vozidla, zvýšen typ průkazu apod.)
  • zpracování žádostí či smluv pro přiznání příspěvků na pořízení a opravy motor. vozidla a dalších příspěvků dle zákona (kompenzační pomůcky a pod.) včetně vedení ekonomických přehledů dle typů příspěvků
  • zajištění dalších tisku rozhodnutí, dopisů či textů (např. autoremedura, postoupení odvolání a podobně)
  • uživatelská konfigurace základních konstant programu (konstanty zákona, poplatky poště, odečítání nebo neodečítání nedoplatku od příští platby, typ výpočtu alikvotní dávky měsíčninami nebo denninami)
  • výpočet a vyplácení dávek a příspěvků dle seznamu možných dávek a příspěvků


Evidence rodin OM

Popis modulu OM - Evidence rodin OM

  • tento modul splňuje instrukci MPSV č.j. 21-12242/2000 ze dne 15.3.2000 včetně článku 24 (díl čtvrtý) o technických nosičích dat !
  • evidence dlužníků, jejich dluhů a vymáhání
  • evidence rodin OM v elektronickém rejstříku se zajištěním požadovaných tisků rejstříků, šetření v rodině a podobně
  • evidence v základním elektronickém rejstříku dětí podle OM a jednotlivých podrejstříků (kartoték) :
    • paternity
    • dohledy
    • cizí péče
    • ústavní výchovy
    • pěstounská péče
    • trestná činnost nezletilých
    • trestná činnost mladistvých
    • příspěvky
    • rozvody
    • výchovy
    • výživné
    • ostatní (drogová závislost, alkoholismus, zneužívání dětí apod.)
    • zápisy (z jednání, šetření v rodině apod.)
  • vyhledání rodin, dětí, občanů, zákonných zástupců i žadatelů podle; OM, RČ, příjmení a jména, typu problému a pod.
  • tisky dle instrukce MPSV č.j. 21-12242/2000
  • rychlé vyhledávání v jednotlivých podrejstřících dle mnoha kritérií
  • zajištění automatizovaného výpočtu měsíčních příspěvků
  • automatizovaný výpočtu "převisů" u příspěvků
  • tisk přehledů z daných kartoték včetně podpory pro roční statistický výkaz
  • ochrana přístupu jednotlivých pracovníků jen k určitým podrejstříkům, (žádný přístup, jen pro prohlížení dat, běžný pracovník, přístup i ke zpracování plateb, administrátor programu)
  • kompatibilita a předávání dat s modulem Ek - evidence kurátora dospělých
  • evidence žadatelů o pěstounskou péči s tiskem dopisů a rozhodnutí
  • evidence žadatelů o osvojení s tiskem dopisů a rozhodnutí
  • prvotní naplnění číselníku obcí z číselníku pošt ČR
  • výpočet a vyplácení dávek a příspěvků dle seznamu možných dávek a příspěvků


Evidence kurátora dospělých

Popis modulu Ek - Evidence kurátora dospělých

  • evidence problémových osob, včetně vedení podrejstříků :
    • návštěvy
    • trestné činnosti
    • peněžité a věcné příspěvky
    • jiné problémy
    • ubytování
    • zápisy
  • evidence základních důležitých informací :
    • rodina a známí
    • vojenská služba
    • zájmy
    • zdravotní záznamy
    • pobyty
    • závazky
    • požitky
    • spolupráce
    • pobyty
    • a další ...
  • tisky vyjádření, dopisů organizacím (včetně případného zaměstnavatele), doporučení (např. k ubytování), návrhů na finanční i nehmotný příspěvek a další
  • tisk základní karty problémového občana
  • tisk "karet" problémového občana dle jednotlivých podregistrů
  • evidence sociálních ubytovacích zařízení okresu a plateb za ně
  • program umožňuje import dat z údajů o trestné činnosti z modulu OM - evidence problémových rodin OM
  • vyhledání občanů podle různých kritérií
  • zjištění rozdílů adres v evidenci a v registru obyvatel a případná aktualizace adres
  • nastavení přístupových práv do podrejstříků
  • výpočet a vyplácení dávek a příspěvků dle seznamu možných dávek a příspěvků


Evidence umisťování

Popis modulu Eu - Evidence umisťování

  • evidence žadatelů o umístění
  • evidence umístěných osob
  • vedení dalších podrejstříků :
    • návštěvy
    • ubytování (DD, ÚSP atd.)
    • ubytování v penziónech)
    • zápisy
  • evidence základních důležitých informací :
    • závazky
    • rodina
    • zájmy
    • spolupráce
    • zdravotní záznamy
    • majetek
    • bytové podmínky
    • rodiče a děti
    • pobyty
    • a další ...
  • uživatelský číselník zařízení včetně ceníku
  • automatizovaný výpočet plateb za pobyt (dle typu pobytu, typu zařízení, typu stravy, plochy atd.) a tisk dokumentů
  • evidence jednotlivých návštěv, umístění v zařízeních nebo penzionech v samostatných podregistrech
  • tisk "evidenčních karet" dle jednotlivých podregistrů
  • zajištění automatizovaného vyhledání volné kapacity umístění dle typu zařízení, počtu lůžek na pokoji a pohlaví žadatele
  • sestavování pořadníku dle různých kritérií
  • plnění dat občanů z registru obyvatel dle RČ nebo příjmení a jména (pokud uvolní administrátor přístup k registru obyvatel)
  • ochrana základního přístupu k datům i podrejstříkům heslem


Evidence půjček a pohledávek

Popis modulu Ep - Evidence půjček a pohledávek

  • evidence úročených a neúročených půjček občanům
  • vedení dalších podrejstříků :
    • návštěvy
    • jednotlivé půjčky
    • zápisy
  • vyhledávání občanů dle RČ, příjmení a jména, typu půjček apod.
  • splátkové kalendáře
  • evidence splátek a pohledávek
  • účetní evidence
  • tisk statistiky a finančních prognóz
  • uživatelská konfigurace půjček - názvy, úročení a pod.
  • proplacení půjčky složenkami "B", bankovním převodem nebo hotově včetně všech nutných dokladů


Evidence sociálních dávek a příspěvků

Popis modulu Ed - Evidence sociálních dávek a příspěvků

  • evidence jednotlivých jednorázových i opakovaných dávek a příspěvků, jak peněžitých, tak i věcných
  • automatizovaný výpočet u typů, kde je vazba na společně posuzované osoby nebo na příjmy a náklady občana
  • vedení dalších podrejstříků :
    • návštěvy
    • jednotlivé příspěvky
    • zápisy
  • vyhledávání občanů dle RČ, příjmení a jména, typu dávek a příspěvků apod.
  • tisk rekapitulací, statistik a finančních prognóz
  • uživatelská konfigurace příspěvků - názvy, limity a pod.
  • proplacení dávek a příspěvků složenkami "B", bankovním převodem nebo hotově včetně všech nutných dokladů
  • výpočet a vyplácení dávek a příspěvků dle seznamu možných dávek a příspěvků


Centrální obsluha registru obyvatel

Popis modulu S1 - Centrální obsluha registru obyvatel

  • Import dat z registru obyvatel MÚ
  • Export dat do uživatelského souboru Dbf pro načtení stávajícími přechodnými programy Soc5Ex_I (nefunkční v demo-verzi)
  • Aktualizace integrovaného číselníku dodávacích pošt ČR z ÚIR-ADR (i pro stávající přechodné programy Soc5Ex_I - nefunkční v demo-verzi)
  • Kontrola vazeb PSČ a názvů pošt v registru obyvatel na PSČ a názvy pošt v ÚIR-ADR
  • Kontrola příslušnosti adresy občana do působnosti úřadu (dle ORP)
Poznámky:
  • Program ke svému běhu potřebuje mít v síti nainstalován Územně identifikační registr (ÚIR-ADR) a to s daty verze 4.1
  • Není třeba, aby byl na stanicích instalován obslužný program "Padr_SQL.exe" z instalačního CD ÚIR-ADR pro import změnových dat, protože přístup k datům je zajištěn naším ODBC driverem; nicméně administrátor by ho měl mít na svém počítači nainstalován, aby mohl aktualizovat data z pravidelných týdenních změnových souborů MPSV (samozřejmě jen případě, že jej nemá integrován na plnohodnotném MS SQL serveru
  • Program má vždy nainstalovánu obsluhu registru obyvatel, ačkoliv je možno registr administrátorsky nakonfigurovat tak, že bude mít prázdná data a z programu bude přístup uživatelům zakázán


Seznam možných příspěvků a dávek

Vysvětlivky jsou pod tabulkou. Popisy dávek nebo příspěvků jsou pouze v heslech z důvodu šířky a délky stránky pro prohlížení a tisk.
Stránka je učena odborníkům nasociální problematiku, pro které je jednoznačným vodítkem pro popis dávky sloupec "Legislativa".
Stručný popis dávky nebo příspěvku | Legislativa | Modul | Typ | Typ výpočtu
provoz motorových vozidel | vyhl.182/1991, §36 | Ei | J-P | *)
navýšené ujeté kilometry | vyhl.182/1991, §36 odst.5 | Ei | J-P | po zadání ujetých km *)
individuální doprava | vyhl.182/1991, §37 | Ei | J-P | *)
kompenzační pomůcky | vyhl.182/1991, §33 | Ei | J-P | ***)
úprava bytu | vyhl.182/1991, §34 | Ei | J-P | ***), ++)
vozidlo - zakoupení, oprava a úprava | vyhl.182/1991, §35 | Ei | J-P | ***), ++)
topná tělesa a nafta | vyhl.182/1991, §39 | Ei | J-P | ***), ++)
telefonní stanice - zřízení a přeložení | vyhl.182/1991, §40 | Ei | J-P | ***), ++)
odchod z ústavu-tělesně postižená mládež | vyhl.182/1991, §41 | Ei | J-PV | ***), ++)
provoz telefonní stanice | vyhl.182/1991, §43 | Ed | O-P | ***), +), vazba na modul Ei
bezbariérový byt a garáž | vyhl.182/1991, §45 | Ed | O-P | ***), +), vazba na modul Ei
krmivo pro vodícího psa | vyhl.182/1991, §46 | Ed | O-P | ***), +), vazba na modul Ei
společné stravování | vyhl.182/1991, §48 | Ed | O-P | ***), +), vazba na modul Ei
příspěvek na výživu dítěte | zákon 482/1991 Sb., §5 | OM | JO-P | *), #), možná změna nákladů
příspěvek na výživu dítěte - zpracování "převisů" | zákon 482/1991 Sb., §5 | OM | JO-P | *), #)
dávka sociální péče | zákon 482/1991 Sb., §4 | Ed | JO-P | **)
mimořádná dávka sociální péče | zákon 482/1991 Sb., §8a | Ed | J-PV | ***)
nezaopatřené děti a těhotné ženy | vyhl.182/1991, §23 | Ed | J-P | ***), +)
základní vybavení a uzavření manželství-PP | vyhl.182/1991, §26 | Ed | J-P | ***), +)
úhrada za užívání bytu-nezaopatřené osiřelé dítě | vyhl.182/1991, §27 | Ed | O-P | ***), ##)
rekreace dětí důchodce | vyhl.182/1991, §28 | Ed | J-P | ***), #)
rekreace a lázeňská péče | vyhl.182/1991, §38 | Ed | J-P | ***), ###)
zvýšené životní náklady | vyhl.182/1991, §42 odst.4 | Ed | O-P | ***)
zvýšené životní náklady - nevidomí | vyhl.182/1991, §42 odst.5 | Ed | O-P | ***), +), vazba na modul Ei
mimořádně obtížné poměry | vyhl.182/1991, §51 | Ed | J-PV | ***)
osoba blízká - dospělá | zákon 100/1988, §80 | Ed | O-P | ***)
osoba blízká - dítě | zákon 100/1988, §81 | Ed | O-P | ***)
dávky společensky nepřizpůsobivým | vyhl.182/1991, §54 | Ek | J-PV | ***)

Vysvětlivky :
Typ příspěvku : J[ednorázový], O[pakovaný], P[eněžitý], V[ěcný]
*) výpočet plně automatizován, nemožná změna částky obsluhou
**) výpočet automatizován, možná úprava částky obsluhou
***) zadání částky obsluhou
+) kontroly limitů dle zákonů a vyhlášek
++) kontroly dle seznamu z ekonomických dat programu
#) vazba na příjmy společně posuzovaných osob
##) vazba na příjem osoby
##) vazba na důchod osoby


Spuštění programu

Spuštění programu:
  • Spusťte program SocM jako jiné programy poklepáním na zástupce programu na ploše nebo jiným způsobem, který Vám doporučí administrátor programu Vašeho úřadu
  • Po spuštění programu si na přihlašovací obrazovce vyberte své jméno a zadejte přístupové heslo, které Vám sdělí administrátor programu
  • Pokud se program nespustí, kontaktujte administrátora programu.


Přihlášení do programu

Při spuštění programu se nejdříve objeví na 10 sekund následující obrazovka pro rychlý vstup hesla:

Pokud zadáte správně své heslo, program Vás přihlásí a pokračuje dál.

Jestliže to nestihnete, nebo zadáte neexistující heslo, objeví se 2.přihlašovací obrazovka:

Pokud po zadání správného hesla stisknete tlačítko "Úprava informací", objeví se obrazovka:

na které si můžete změnit některé přihlašovací informace.

Důležité informace:
  • Zadávání hesla je "case sensitive", takže rozlišuje malá a velká písmena.
  • Po stisku tlačítka "Úprava informací" se současně prakticky zastaví odpočítávání času pro ochranu vstupu hesla, abyste na změny měli dostatek času.
  • Pokud jste přihlášen jako "Administrátor programu", můžete změnit jen Vaše heslo.

Nedaří se Vám přihlásit do programu ?


Nemohu se přihlásit do programu

Postupujete správně při přihlášení do programu ?

Zkontrolujte:
  • Je v číselníku hesel Vaše příjmení?
    Kontaktujte administrátora programu na Vašem úřadu, který může Vaše jméno přidat do číselníku hesel.
  • Nemáte zapnutou klávesu 'Caps Lock'?
    U hesla se rozlišují malá a velká písmena?
  • Nemáte v hesle 'česká písmena' nebo znaky 'y' či 'z' a klávesnici přepnutou v režimu 'CZ' (nebo ji máte v jiném režimu)?
    Přepněte klávesnisnici do správného režimu a zkuste znovu
  • Nestihnete se přihlásit?
    Kontaktujte administrátora programu na Vašem úřadu, ten může nastavit delší čas k přihlášení.
  • 'Zrychleně' zadáte svoje heslo a je přihlášen jiný pracovník?
    Kontaktujte administrátora programu na Vašem úřadu, protože má i jiný pracovník stejné heslo.
  • Pořád si nevíte rady?
    Kontaktujte administrátora programu na Vašem úřadu nebo dodavatele programu !


Nemožný přístup k datům

V některých případech je pro provedení akce nutný výhradní přístup k datům (například pokud chcete opravovat parametry programu, nesní program běžet současně na jiné stanici).
Pak se může stát, že po volbě systémové akce uvidíte následující upozornění

Také se může stát, že po volbě standardní akce Vám program zobrazí "vyčkávací" obrazovku:

Znamená to, že některá stanice v síti v dané chvíli upravuje data, která chcete měnit i Vy.
Pak nezbývá než čekat na uvolnění (program si pravidelně testuje, zda je přístup již možný) nebo tlačítkem "Nečekat dále" ukončit akci a provést ji později.

V konfiguraci programu může počet opakování pokusů i interval mezi nimi zvýšit "Administrátor programu" s prioritou přístupu 5.


Tisk přehledů a rekapitulací

Tisky různých přehledů program zajišťuje :
  • přímým výstupem pro "Textový editor" (např. Word) případně pro "Tabulkový procesor" (např. Excel), pokud je tato možnost nastavena v konfiguraci stanice a program to v daném místě umožňuje
  • standardně (obrazovka nebo tiskárna) - umožněno vždy
    • .
Pokud je to při tisku v dané chvíli možné, objeví se Vám obrazovka pro volbu typu výstupu:

na které si můžete zvolit, kam má program přehled vytvořit.

Pokud zaškrtnete volbu "Obrazovka (případně tiskárna)", objeví se Vám nejdříve okno, kde si můžete vybrat, kam chcete tisknout:

Z uvedené obrazovky můžete tisknout opakovaně i vícekrát tak dlouho, dokud nestisknete tlačítko "Ukončit tisky".

Pokud zvolíte "Tiskárna", program předá tisk "správci tisku Windows", který Vám zobrazí dialog správce tisku , kde si můžete upřesnit podrobnosti tisku (například počet kopií, kvalitu, tisk jen některých stran a podobně).

Pokud zvolíte "Obrazovka", zobrazí se Vám náhled tisku:.

Důležitá upozornění:
  • Tlačítkem [image] v okně náhledu je předán tisk vždy na implicitní tiskárnu !
  • Tlačítkem [image] v okně náhledu je předán vždy tisk všech stran přehledu !
  • Tlačítka se šipkami v okně náhledu slouží k posuvu po stranách v náhledu !
  • Text v záhlaví okna náhledu v lomených závorkách je interní jméno formátu tisku. Formáty standardních tisků jsou uloženy v podadresáři "RepoForm\" programu. K úpravám formátu je určen speciální program, který Vám v případě potřeby můžeme zaslat .


Volba výstupu generování textu

Na obrazovce zvolte, jakým programem chcete výstup tisknout, případně i upravit.

Přitom nemusí být vysvíceny některé volby, vše záleží na tom,zda program při svém startu na Vaší stanici detekoval:
  • nainstalovaný Microsoft Word
  • nainstalovaný Internet Explorer
  • administrátorem nastavený externí editor textu
  • administrátorem nastavený externí editor Html
    • .
Nastavení externích editorů provádí administrátor programu v konfiguraci stanice .


Konfigurace stanice

Konfiguraci stanice může upravovat pouze administrátor programu, který má prioritu přístupu 5 .
Důležité:
Opravu konfigurace stanice je nutno provést přímo na stanici, jejíž konfigurace se má měnit !

Vstup do následující obrazovky, kde je možno opravovat konfiguraci stanice, provede administrátor programu
z hlavní nabídky programu volbou "Parametry" - "Této stanice v síti":


Program Socm_Adm.Exe

Slouží k povolení nebo zakázání spouštění programů SocM a SocmInde v síti, například při a po provádění údržby programu, provádění update a podobně.

Poznámky:
  • Program vyžaduje speciální heslo, které můžete nastavit v systémových parametrech programu Socm.
  • Při zakázání běhu programů SocM je vyžadováno zadání předpokládaného povolení spouštění programů
 Následují dvě ukázky možných obrazovek programu SocM_Adm:

Zakázání běhu:

Povolení běhu:


Oprava číselníku hesel

Číselník hesel může upravovat pouze administrátor programu na Vašem úřadu , který má prioritu přístupu 5 .

Vstup do následující obrazovky, kde je možno opravovat hesla, provede administrátor programu
z hlavní nabídky programu volbou "Systém" - "Oprava číselníku" - "Hesel".

Následuje příklad, kde je možno jednotlivé položky přidávat a případně i upravovat:

Pomocí tlačítek "Oprava dalších informací" a "Oprava číselníku útvarů" také můžete opravit další informace:


Registr obyvatel

Chcete přímo jen pokyny k obsluze registru obyvatel?

Chcete si přečíst stručný popis hlavních funkcí modulu?

1. Základní informace

Program používá své soubory se šifrovanými daty registru obyvatel (dále jen RO).
Údaje o občanech je možno naimportovat z datové základny Evidence obyvatel MÚ, to jest ze souborů "*.UNL*
  • dle "Informace č.176 pro obce z 24.03.2003 Odboru informatizace veřejné správy MV ČR s Č.j:OIS-6-10/1-2003"
  • nebo "Informace č.184 pro obce z 20.11.2003 Odboru informatizace veřejné správy MV ČR s Č.j:OIS-6-10/1-2003."
Data musí být připravena k importu v kódování Windows 1250

2. Informace pro administrátory programu

  • Program SocM ukládá data do souborů šifrované pomocí šifrovací knihovny CryptPak.Dll
  • Pro import dat z Evidence obyvatel ČR (dále jen EO) je potřebné stáhnout všechny soubory dle tabulky, uvedené níže
  • Administrátor programu po importu může v programy SocM nastavit tři úrovně přístupu k datům RO:
    • Žádný přístup - program uživateli vypisuje hlášení "Nenalezen registr obyvatel"
    • Plný přístup - program uživateli zobrazuje všechny údaje o občanovi
    • Přístup bez podrobností - program uživateli nezobrazuje podrobná data občana
  • Při importu dat z EO (Evidence obyvatel) do RO SocM nemůže běžet program SocM na žádné jiné stanici

3. Seznam potřebných souborů k importu

Pro import dat musíte mít k dispozici z Evidence obyvatel MÚ VŠECHNY POTŘEBNÉ SOUBORY.

4. Popis logického importového modulu programu SocM při importu dat

Pro každý záznam z EO (každého občana):
  • V základní souboru se zjistí PČO (počítačové číslo osoby) a načte se PCD (počítačové číslo domu bez kontrolní číslice)
  • Hledá se adresní kód v databázi ÚIR-Adr pro zjištěné PCD
  • Pokud je PCD nalezeno, převezme se adresa z ÚIR-ADR, pokud PCD nalezeno není
    • Zjistí se základní adresní údaje v podpůrných souborech vazeb a proběhne vyhledání v databázi ÚIR-Adr podle nich
    • Pokud jsou adresní údaje nalezeny, převezme se adresa z ÚIR-ADR, pokud ne
      • Občan je vyloučen z dalšího zpracování, informace je uložena do chybového souboru
  • Zjistí se další informace a proběhnou základní testy (např. rozsah číselníkových položek, správnost RČ, úplnost povinných údajů a pod. v EO)
    • Pokud neproběhnout testy O.K., Občan je vyloučen z dalšího zpracování, informace je uložena do chybového souboru
  • Pokud nebyl občan vyloučen již dříve, proběhnou doplňující testy s "varováním", které když nedopadnou O.K., občan není vyloučen z dalšího zpracování ale informace je pouze jako varování uložena do chybového souboru (například R.Č. otce má za lomítkem chybné znaky a další)
Po zpracování všech položek z EO:
  • Proběhnou testy RO jako celku (například duplicity RČ a podobně)
  • Pokud jsou nalezeny chybné vazby
    • Občané jsou vyloučeni z dalšího zpracování, informace jsou uloženy do chybového souboru
  • Program nabídne možnost zobrazení a tisku rekapitulace varování a chyb
  • Import je ukočen, bezchybná data jsou zakryptována a uložena do RO

5. Provedení importu dat v programu

Návod k provedení importu dat je v pokynech k obsluze registru obyvatel.


Seznam souborů pro import z EO

Seznam potřebných souborů k importu

Důležité upozornění: Soubory musí být v kódování Windows 1250 !!!

Pro import dat musíte mít v jednom adresáři, který je v síti přístupný všechny následující soubory, získané z EO MÚ:
  • Základní soubor:
    • ZVO_XXXXXX.unl kde XXXXXX je prvních 6 znaků názvu obce
  • Podpůrné soubory vazeb:
    • ADRESA.unl
    • LOKALITA.unl
    • OKRES.unl
    • ULICE.unl
    • ULICE_TXT.unl


Oprava číselníku názvů stanic

Číselník názvů stanic může upravovat pouze administrátor programu na Vašem úřadu , který má prioritu přístupu 5 .

Vstup do následující obrazovky, kde je možno opravovat hesla, provede administrátor programu
z hlavní nabídky programu volbou "Systém" - "Oprava číselníku" - "názvů stanic".

Upozornění:
  • Při úpravě je k dispozici speciální nabídka s volbami, ukočení oprav provedete volbou konec
  • Černě označené položky budou po ukončení smazány
  • Obsah číselníku je možno po ukončení oprav vytisknout
Následuje příklad, kde je možno jednotlivé položky přidávat a případně i upravovat:


Obecné informace o použití maker

Seznamy použitelných maker :
  • Základní makra uživatele programu (použitelná ve všech vzorech)
  • Základní makra adresáře osob (použitelná ve všech vzorech)
  • Speciální makra rejstříku zápisů (použitelná při generování z obrazovky zápisů)
    • .

Základní informace o použití maker:
Makra slouží k naplnění proměnných hodnot do generovaného textu. Celé makro je při generování nahrazeno aktuálním textem z evidence programu.

Každé makro je ve tvaru "začátek makra (znak ©)", Identifikace makra (dle seznamu maker) a "konec makra (znak ®)", přitom si nemusíte dělat starosti, jak napsat znaky začátku a konce makra na anglické nebo české klávesnici, protože při úpravě vzorů je k dispozici speciální nabídka pro vkládání dat do vzoru, ze které můžete ukázkové makro vložit.
Tak například zapsané makro: ©Q[51]® bude nahrazeno aktuálním datem z počítače ve tvaru dd.mm.rrrr.

Použití grafiky ve vzorech:
Do vzoru můžete také vložit grafický obrázek formátu Bmp, Gif nebo JPG ve tvaru:
©@@ Image="plná_cesta_a_jméno_grafického_souboru"®
Například pokud na začátek vzoru umístíte makro ©@@ Image="L:\Obrazky\Hlavicka_MU.gif"® , bude vždy po generování uvedený grafický soubor zobrazen textovým editorem na začátku dokumentu.

D o p o r u č e n í:
  • Makra, která v seznamu jsou ve skupině 'Celé tabulky', jsou nahrazeny tabulkou a makro by mělo být umístěno hned na začátku řádky za znakem nového řádku
  • Makra, která v seznamu jsou ve skupině 'Makra "Memo', jsou nahrazeny textem z poznámkové položky Memo, který může být různě dlouhý (například i na 1 a 1/2 stránky); makro by proto mělo být umístěno hned na začátku řádky za znakem nového řádku
  • Grafický soubor pro vložení by měl být připraven tak, aby jeho velikost nemusel textový editor již měnit (aby nedošlo ke zmenšení či zvětšení obrázku textovým editorem a tím i ke snnížení kvality tisku)
  • Pracujete ve Windows a tak je třeba mít na zřeteli, že i z této nápovědy můžete kus textu (třeba makro pro obrázek) kopírovat a vložit do vzoru (a tam třeba jen změnit název souboru)
  • Ne všechna makra v číselných řadách jsou využita, některá složí k vývoji programu; na použití nevyužívaných maker Vás program při generování upozorní
  • Pokud chybně zapíšete makro (například zapomenete znak konce makra), program Vás na to nejen upozorní, ale zastaví generování a první chybný úsek mám ve vzoru graficky vyznačí
Informace pro adminustrátory programu:

  • Implicitní přednastavení stylu dokumentu:
    • Při generování dokumentu program sám přidá do dokumentu sekci Head - /Head
    • Do uvedené sekce vloží sekce Style - /Style s definicí "Style v Body" z ini souboru
    • Ini soubor může upravit administrátor programu v systémových parametrech programu Socm
  • Implicitní přednastavení fontu v tabulkách:
    • Při generování dokumentu je v tabulkách adres implicitní font v implicitní výšce
    • V systémových parametrech programu Socm může administrátor programu nastavit kondenzovaný font "Arial Narrow" o velikosti 10pt


Seznam maker - uživatel programu

1. Uživatel programu (úřad) :

Typ | Skupina | Popis | Makro
Makra textů |  |  |
 | Úřad | Název | ©Q[1]®
 | Adresa úřadu | 1.řádek adresy | ©Q[2]®
 |  | 2.řádek adresy | ©Q[3]®
 |  | 3.řádek adresy | ©Q[4]®
 |  | Jen PSČ (5 znaků) | ©Q[6]®
 |  | Jen PSČ (3+2 znaky) | ©Q[7]®
 |  | Jen název pošty | ©Q[8]®
 | Působnost úřadu | Název ORP | ©Q[9]®
 | Název úřadu | Ve 2.pádu | ©Q[10]®
 |  | Ve 3.pádu | ©Q[11]®
 |  | Ve 4.pádu | ©Q[12]®
 |  | V 5.pádu | ©Q[13]®
 |  | V 6.pádu | ©Q[14]®
 |  | V 7.pádu | ©Q[15]®
 | Město úřadu | Ve 2.pádu | ©Q[16]®
 |  | Ve 3.pádu | ©Q[17]®
 |  | Ve 4.pádu | ©Q[18]®
 |  | V 5.pádu | ©Q[19]®
 |  | V 6.pádu | ©Q[20]®
 |  | V 7.pádu | ©Q[21]®
 | Bankovní spojení 1 | Název banky | ©Q[22]®
 |  | Kód banky | ©Q[23]®
 |  | Předúčet | ©Q[24]®
 |  | Číslo účtu | ©Q[25]®
 |  | Konstantní symbol platby | ©Q[26]®
 | Bankovní spojení 2 | Název banky | ©Q[27]®
 |  | Kód banky | ©Q[28]®
 |  | Předúčet | ©Q[29]®
 |  | Číslo účtu | ©Q[30]®
 |  | Konstantní symbol platby | ©Q[31]®
 | Útvar pracovníka | Název útvaru v 1.pádu | ©Q[41]®
 |  | 1.řádek adresy | ©Q[42]®
 |  | 2.řádek adresy | ©Q[43]®
 |  | 3.řádek adresy | ©Q[44]®
 |  | Jen PSČ (5 znaků) | ©Q[45]®
 |  | Jen PSČ (3+2 znaky) | ©Q[46]®
 |  | Jen název pošty | ©Q[47]®
 |  | Vedoucí útvaru | ©Q[48]®
 |  | Funkce vedoucího útvaru | ©Q[49]®
Celé tabulky |  |  |
 | Adresa úřadu | 1 sloupec bez útvaru | ©QT[1]®
 |  | 2 sloupce bez útvaru | ©QT[2]®
 |  | 1 sloupec s útvarem | ©QT[3]®
 |  | 2 sloupce s útvarem | ©QT[4]®

2. Systémová makra :

Typ | Skupina | Popis | Makro
Makra textů |  |  |
 | Datum a čas | Aktuální datum | ©Q[51]®
 |  | Aktuální čas | ©Q[52]®
 |  | Včerejší datum | ©Q[53]®
 |  | Zítřejší datum | ©Q[54]®
 | Pracovník obsluhy | Příjmení a jméno | ©Q[55]®
 |  | Vyřizuje (z číselníku hesel) | ©Q[56]®
 |  | Telefon (z číselníku hesel) | ©Q[57]®
 |  | E-mail (z číselníku hesel) | ©Q[58]®
Generování |  |  |
 | Zadáno při generování | Datum 1 | ©Q[96]®
 |  | Datum 2 | ©Q[97]®
 |  | Datum 3 | ©Q[98]®
 |  | Další Č.J. | ©Q[99]®
 |  | Celé Č.J. (tvar dle nastavení) | ©Q[100]®
Konec Seznamu maker - uživatel programu
Základní informace o použití makrech


Seznam maker - adresář osob

Základní údaje o osobě :

Typ | Skupina | Popis | Makro
Makra textů |  |  |
 | Rodné číslo | nebo text R.Č. neuvedeno | ©QQ[1]®
 | Narození | Datum | ©QQ[2]®
 | Příjmení | v 1.pádu | ©QQ[3]®
 | Příjmení | v 5.pádu - oslovení | ©QQ[33]®
 | Jméno | v 1.pádu | ©QQ[4]®
 | Jméno | v 5.pádu - oslovení | ©QQ[34]®
 | Titul | Před jménem | ©QQ[5]®
 |  | Za jménem | ©QQ[6]®
 | Příjmení a jméno |  | ©QQ[7]®
 | Jméno a příjmení |  | ©QQ[8]®
 | Příjmení a jméno | Včetně titulů | ©QQ[9]®
 | Jméno a příjmení | Včetně titulů | ©QQ[10]®
 | Rodné příjmení |  | ©QQ[11]®
 | Věk | K aktuálnímu dni | ©QQ[12]®
 | Rodiný stav |  | ©QQ[13]®
 | Národnost |  | ©QQ[14]®
 | Státní příslušnost |  | ©QQ[15]®
 | Přípona slovesa | "a" (u ženy), nic u muže | ©QQ[32]®
 | 1.pád Oslovení | Pan, Paní resp. Slečna | ©QQ[16]®
 | 1.pád Oslovení | dtto, ale Vážený, Vážená ... | ©QQ[17]®
 | 5.pád Oslovení | Pane, Paní resp. Slečno | ©QQ[37]®
 | 5.pád Oslovení | dtto, ale Vážený, Vážená ... | ©QQ[38]®
 | Adresa - základní | 1.řádek adresy | ©QQ[18]®
 |  | 2.řádek adresy | ©QQ[19]®
 |  | 3.řádek adresy | ©QQ[20]®
 |  | Jen PSČ (5 znaků) | ©QQ[21]®
 |  | Jen PSČ (3+2 znaky) | ©QQ[22]®
 |  | Jen název pošty | ©QQ[23]®
 |  | Typ adresy (pobytu) | ©QQ[24]®
 |  | Platnost adresy (pobytu) Od | ©QQ[25]®
 | Adresa - Kontaktní | 1.řádek adresy | ©QQ[26]®
 |  | 2.řádek adresy | ©QQ[27]®
 |  | 3.řádek adresy | ©QQ[28]®
 |  | Jen PSČ (5 znaků) | ©QQ[29]®
 |  | Jen PSČ (3+2 znaky) | ©QQ[30]®
 |  | Jen název pošty | ©QQ[31]®
Makra "Memo" | makro umístit na začátku řádky |  |
 | Zapsané : | Bydlení | ©QQ[81]®
 |  | Evidován | ©QQ[82]®
 |  | Majetek | ©QQ[83]®
 |  | Pobyty | ©QQ[84]®
 |  | Požitky | ©QQ[85]®
 |  | Rodina | ©QQ[86]®
 |  | Spolupráce | ©QQ[87]®
 |  | Vojna | ©QQ[88]®
 |  | Zájmy | ©QQ[89]®
 |  | Zaměstnání | ©QQ[90]®
 |  | Závazky | ©QQ[91]®
 |  | Zdraví | ©QQ[92]®
 |  | Spisy | ©QQ[93]®
 |  | Rozhodnutí | ©QQ[94]®
 |  | Poznámky | ©QQ[95]®
 |  | Systém | ©QQ[96]®
Celé tabulky |  |  |
 | Adresa - Základní |  |
 | Bez oslovení | Do 1 sloupce tabulky | ©QQT[1]®
 |  | PSČ v samostatném sloupci | ©QQT[2]®
 | S oslovením | Do 1 sloupce tabulky | ©QQT[3]®
 |  | PSČ v samostatném sloupci | ©QQT[4]®
 | S "Váženým" oslovením | Do 1 sloupce tabulky | ©QQT[5]®
 |  | PSČ v samostatném sloupci | ©QQT[6]®
 | Adresa - Kontaktní |  |
 | Bez oslovení | Do 1 sloupce tabulky | ©QQT[11]®
 |  | PSČ v samostatném sloupci | ©QQT[12]®
 | S oslovením | Do 1 sloupce tabulky | ©QQT[13]®
 |  | PSČ v samostatném sloupci | ©QQT[14]®
 | S "Váženým" oslovením | Do 1 sloupce tabulky | ©QQT[15]®
 |  | PSČ v samostatném sloupci | ©QQT[16]®
Konec Seznamu maker - adresář osob
Základní informace o použití makrech


Seznam maker - Osoby - Zápisy

Základní údaje o osobě :

Typ | Skupina | Popis | Makro
Makra textů |  |  |
 | Vyřizuje | Příjmení a jméno | ©QQ[101]®
 | Datum zápisu |  | ©QQ[102]®
 | Typ zápisu |  | ©QQ[103]®
 | Popis zápisu |  | ©QQ[104]®
 | Konec zápisu | Datum | ©QQ[105]®
 |  | Důvod | ©QQ[106]®
 | Archivace zápisu | Datum | ©QQ[107]®
 |  | Kdo archivoval | ©QQ[108]®
Makra "Memo" | makro umístit na začátku řádky |  |
 | Zapsaný zápis |  | ©QQ[199]®
 | Zapsané poznámky |  | ©QQ[200]®
Konec Seznamu maker - Osoby - Zápisy
Základní informace o použití makrech


Administrátorské práce

Někdy se Vám může stát, že se po startu programu objeví následující obrazovka:

Důvod je patrný již z textu na obrazovce.
Volba povolení startu programu vyžaduje heslo, které zná Administrátor programu.

Administrátor programu také může spustit speciální program Socm_Adm.Exe a může běh programu se stejným heslem zakázat:


Adresář osob - Hlavní obrazovka

Přístup k jednotlivým údajům je dán jednak prvotně Prioritou pracovníka, ale sekundárně též administrátorem nastavenými právy v číselníku hesel.

Přístup k obrazovce: Hlavní nabídka - Akce - Ukaž, případně horká klávesa "Ctrl+A"

Obrazovka je rozdělena do tří oblastí:
  • horní, informativní část, kde jsou zobrazovány základní údaje, vyznačená v ukázce červeně
  • střední, údajová část (má pět záložek) s údaji o osobě, vyznačená v ukázce zeleně
  • dolní, akční část, kde jsou tlačítka pro různé akce, vyznačená v ukázce fialově
Žluté popisy jsou na ukázce jen pro účely této nápovědy a na skutečné obrazovce nejsou.

Poznámky:
  • Tlačítka na obrazovce mají buď plnohodotný text jejich funkcí, nebo nápovědu Windows (stačí na tlačítko přesunout ukazatel myši a zobrazí se nápověda)
  • Následující záložky obrazovky jsou naplněny fiktivními údaji
  • Následující záložky obrazovky zobrazují stav k aktuální verzi programu
 Následuje ukázka obrazovky po stisku tlačítka pro zobrazení kontaktní adresy (Horká klávesa "n") a výpisu informace o poštovní kontaktní adrese občana:


Adresní místo - výběr adresy

Chcete si přečíst základní informace?

Obrazovka slouží k naplnění adresního místa.

Veškeré informace jsou pod ukázkou obrazovky:

Postup:
  • Vyberte obec - Tlačítko "Obec v působnosti", pokud nespadá do oblasti Vaší působnosti, Tlačítko "Obec v celé ČR"
  • Vyberte ulici - Tlačítko "Ulice" (pokud je nevysvícené, vybraná obec nemá ulice)
  • Zadejte číslo popisné, případně orientační
  • Zkuste vyhledat adresní místo dle zadaných kritérií - Tlačítko "Vyhledat adresu"
  • Vybranou adresu uložte - Tlačítko "Uložit data"
Poznámky:
  • Čím více údajů zadáte, tím je nalezení adresního místa v ÚIR-ADR rychlejší
  • Pokud není adresní místo dle Vašich kritérií nalezeno, vymažte ulici, čísla a zkuste znovu vyhledat adresní místo dle nových kritérií
  • Pokud je nalezeno více adresních míst, vyberte správné ze seznamu, který Vám program nabídne
  • Pokud nějaké adresní místo zvolíte, program sám doplní na obrazovce nevyplněné údaje
  • Na obrazovce se v průběhu výběru dle Vašich kritérií mohou zobrazovat i další informace či tlačítka
Následují 2 ukázky se zelenými komentáři po výběru adresního místa:


Adresní místo - výběr náhradní adresy

Chcete si přečíst základní informace?

Může se stát, že adresní místo s Vámi zadaným domovním nebo orientačním číslem není v ÚIR-ADR nalezeno.

V tom případě doplňte k vybranému adresnímu místu náhradní domovní nebo orientační číslo (případně obě) a zvolte tlačítko "Použít náhradní adresu".

Následuje ukázka vyplnění:


Adresní místo - výběr ze seznamu

Chcete si přečíst základní informace?

Je-li nalezeno dle zadaných kritérií více adresních míst, objeví se obrazovka se seznamem nalezených adresních míst, kde můžete vybrat tu adresu, která je správná:

Následuje 1. ukázka seznamu:

Pokud je nalezeno více adresních míst, je vysvíceno i tlačítko pro hledání.
Následuje 2. ukázka seznamu (po stisku tlačítka hledání):


Informace o PC a z Logo souboru

Priorita přístupu:
Výpis systémových chyb: 5
Výpis údajů z logo souboru: 2

Spuštění: Hlavní nabídka - Informace - Systémové údaje - Počítač a program

Následuje ukázka obrazovky, kde i z logo souboru můžete zadáním ID osoby najít informace, co vše se v historii s osobou dělo:


Oprava čísel jednacích

Oprava údajů: 4, ostatní jen prohlížení
Spuštění: Hlavní nabídka - Parametry - Programu - Uživatelské - Tvar č.j. a číslování

Obrazovka nastavení tvaru číselsel jednacích má dvě záložky.
Postup práce:
Na první si nastavíte obecně tvar č.j. pro celý program
Na druhé si nastavíte volitelné parametry pro jednotlivé sady č.j..

Důležité informace:
  • Je třeba, abyste vynulovali na začátku roku na 2.záložce aktuální poslední čísla
  • Aktuální poslední čísla nelze změnit, ale budou změněna automaticky po generování a archivaci tisku.
Následuje ukázka možného nastavení
POZOR: zobrazené údaje jsou fiktivní

1.Záložka

2.Záložka - po stisku tlačítka pro zobrazení ukázky č.j.


Parametry komunikace se SSP

Priorita přístupu 5
Spuštění: Hlavní nabídka - Parametry - Komunikace - SSP (dotaz-odpověď) Obrazovka nastavení parametrů má dvě záložky, po ukončení úprav je možno přehled nastavení vytisknout.

Na první je třeba zadat údaje o odesílateli a příjemci.
Potřebné údaje Vám dodá administrátor, který se stará o provoz SSP.
Doporučujeme pro ověření předávání dat nejdříve vyzkoušet předávání dat bez CRC (předávaný soubor je možno při pokusech importu ve SSP editovat) a po ukončení ověření zapnout volbu přidávání CRC.

Jaké údaje nastavit na druhé záložce by měli vědět pracovníci sociálního referátu (při importu dat ze SSP jsou zapracovány jen vybrané položky, ostatní jsou v příjmech osoby ze SSP ignorovány).


Parametry proplácení příspěvků

Priorita přístupu: 4
Spuštění: Hlavní nabídka - Parametry - Programu - Uživatelské - Proplácení dávek

Důležité informace:
  • všechny záložky budou zpřístupněny po aktivaci modulu "F"
Obrazovka nastavení parametrů má 6 záložek.

Následuje ukázka možného nastavení:

1.Záložka


Parametry komunikace s ÚP

Priorita přístupu 5
Spuštění: Hlavní nabídka - Parametry - Komunikace - Úřad práce (dotaz-odpověď)

Na velmi jednoduché obrazovce stačí zadat Úřadem práce přidělený kód :


Parametry útvarů

Oprava údajů: 4, ostatní jen prohlížení
Spuštění: Hlavní nabídka - Parametry - Uživatel programu - Konfigurace útvarů

Obrazovka nastavení útvarů má tři záložky.
Postup práce:
Na první si vyberte útvar
Na dalších 2 záložkách opravte údaje.

Důležité informace:
  • V programu je připraveno 10 útvarů uživatele, z toho uživateli přístupných je 8
  • Každý útvar může mít samostatnou adresu
  • Pokud není některý útvar povolen, kontaktujte administrátora programu, který jej může v číselníku hesel povolit/zakázat
  • Každý útvar má pro generování jednu skupinu z devíti sad č.j., označenou číslicemi 1 až 9, přitom přidělení čísla sady můžete nastavit na 2.záložce
  • Každý pracovník v číselníku hesel má přidělen útvar
Následuje ukázka možného nastavení
POZOR: zobrazené údaje jsou fiktivní

1.Záložka

2.Záložka

3.Záložka


Registr obyvatel - Parametry přístupu

Priorita přístupu: 5
Spuštění: Hlavní nabídka - Parametry - Programu - Systémové - Vyhledávání v registru obyvatel

Informace:
  • Pokud chcete, aby se zobrazovaly uživatelům i podrobnosti (R.Č. dětí, údaje z matriky a pod.), zaškrtněte patřičnou volbu, v opačném případě nebudou podrobné údaje na informační obrazovcez registru obyvatel vidět
  • Při výběru obcí z registru obyvatel je nabízen seznam všech obcí ORP; po zaškrtnutí volby "zápise" je SQL příkaz do ÚIR-Adr omezen jen na obce, jejichž název začíná textem, který uživatel zapíše
Následuje ukázka možného nastavení:


Podrobnosti v Registru obyvatel

Z registru obyvatel si můžete zobrazit i podrobné doplňující informace.

Důležité informace:
  • Pokud se Vám nezobrazí jako na ukázce červeně zarámované údaje, je to dáno tím, že zobrazování podrobností z registru obyvatel administrátor programu zakázal!
  • Samozřejmě místo v ukázce úmyslně tmavě šedě vymazaných údajů jsou uvedena reálná data
 Následuje ukázka možného zobrazení:


Rozdíly v Registru obyvatel

Pokud máte již některé údaje o osobě vyplněny, po stisku tlačítka "Data v registru obyvatel" Vám program zobrazí obrazovku, kde jsou rozdílné údaje žlutě podsvíceny a Vy můžete data převzít do evidence, nebo je nepřebírat.

Důležité informace:
  • Samozřejmě místo v ukázce úmyslně tmavě šedě vymazaných údajů jsou uvedena reálná data
  • Pokud jsou data totožná, není žádné pole žlutě podsvíceno a tlačítko "Převzít označené položky z registru" je neaktivní
 Následuje ukázka možného zobrazení:


Hledání v Registru obyvatel

Při vkládání nového občana do evidence se nejdříve objeví obrazovka pro hledání v registru obyvatel, kde můžete hledat dle RČ nebo podle části příjmení a jména:

Pokud víte, že RČ je správné a občan nebyl nalezen v registru obyvatel, nebo v případě, že jste si jisti, že tam nemůže být, můžete hned akci zrušit, objeví se Vám druhá obrazovka pro vkládání občana, kde datum narození je nutno vyplnit jen v případě neuvedení rodného čísla:


Systémové parametry programu

Priorita přístupu: 5
Spuštění: Hlavní nabídka - Parametry - Programu - Systémové - Celého programu v síti

Obrazovka nastavení parametrů má čtyři záložky, snad pro administrátory programu není třeba význam položek komentovat.

Za zmínku snad stojí dvě důležité věci:
  • Soubor logo je možno vyprázdnit na třetí záložce (potřebnost vyprázdnění souboru hlásí uživatelům indexační program po překročení Vámi zadaného limitu počtu záznamů)
  • Načíst zaslaný licenční soubor '*.SocM' je možno na čtvrté záložce
Následuje ukázka možného nastavení:
1.Záložka

2.Záložka

3.Záložka

4.Záložka, za ní je ještě 1 ukázka obrazovky

4.Záložka po stisku tlačítka "Informace o stávající licenci", kde se můžete přesvědčit o aktuálním stavu Vaší licence k programu


Systémové parametry uživatele

Priorita přístupu k opravám (ostatní jen prohlížení):
Oprava ORP působnosti úřadu: 5
Oprava ostatních údajů: 4
Spuštění: Hlavní nabídka - Parametry - Uživatel programu - Adresa a působnost

Důležité informace:
  • Působnost automaticky načítána z licenčního souboru.
  • Změna působnosti je jen pro nouzové nastavení v případě, že:
    • jste při 1.spuśtění demoverze vybrali špatnou oblast působnosti
    • že po načtení licenčního souboru je oblast chybná (o této skutečnosti dodavatele programu informujte!)
  • Hlavní adresa úřadu je automaticky načítána z licenčního souboru (pokud je tam adresa chybná, informujte o tom dodavatele programu)
  • Vždy vybírejte hlavní adresu úřadu, v číselníku útvarů jsou adresy pro každý útvar zvlášť
 Obrazovka nastavení parametrů má tři záložky.
Následuje ukázka možného nastavení
POZOR: zobrazené údaje jsou fiktivní

1.Záložka

2.Záložka

3.Záložka


Výběr a tisk z archívu tisků

Obrazovka umožní selektivně vybrat a znovu předat k tisku archivované texty.

Informace:
  • Při spuštění tisku z archívu na 5. záložce občana není volba "Ident. osoby vysvícena" a naopak při spuštění tisku z archívu z hlavní nabídky programu vysvícena je a pokud ID osoby neuvedete, budou vybírany archivní tisky pro všechny osoby
 Po zadání kritérií pro výběr Vám program zobrazí seznam nalezených tisků v archívu k akci (tisk seznamu archívu, opakované předání tisku externímu editoru)

Následuje ukázka obrazovky (základní obrazovka je oříznuta):


Výběr dat k tisku

Tato obrazovka slouží k výběru dat pro tisk ze základní evidence občanů.

K jednotlivým volbám je snad možno dodat jen to, že pokud některé údaje pro výběr nemají smysl, jsou volby zakázány nebo nejsou vidět vůbec.

Ukázka:


Výběr data narození

Pokud není datum narození jednoznačně určitelné z rodného čísla, musíte na následující obrazovce vybrat jednu ze dvou možností.

Příklad v následující ukázce NENASTANE:
- v případě, že je administrátorem programu nastavena volba "Při převodu RČ na datum narození zjistit rok narození dle kontrolky RČ" v systémových parametry programu.
Program v tom případě vybere datum narození podle existence 4.číslice za lomítkem R.Č.


Výběr z nabídky

Příklad výběru:

Při výběru se můžete pohybovat pomocí myši nebo kláves nahoru a dolů, můžete používat i klávesy PageDown a PageUp.
Můžete použít i jiné klávesy - např. stisknete-li v ukázce "ve" (s odstupem maximálně 1/2 sekundy mezi oběma písmeny), vybarví se první položka, začínající zadaným textem (Velká Polom)
Potvrzení výběru provedete klávesou Enter, nebo "dvojklikem" myši.
Poznámky :
  • horní tlačítko má proměnlivý text, někdy je i vysvícené s nápisem "Nic nevybrat", případně "Zrušit akci" a podobně
  • výška okna se podle počtu položek k výběru zvětšuje
  • při dosažení maximální výšky se vysvítí pravá svislá posuvníková lišta


Změna rodného čísla

Změnit rodné číslo můžete červeným tlačítkem na poslední záložce Hlavní obrazovky Adresáře osob.

Důležité informace:
  • Můžete změnit jen znaky za lomítkem RČ
  • Nové R.Č. je testováno nejen obsahově, ale i na existenci jiné osoby s týmž rodným číslem
  • Začátek R.Č. (čísla před lomítkem) zajišťuje dle data narození a pohlaví osoby sám program
  • Pokud Vám program nabídne chybný začátek R.Č., zrušte akci a nejříve opravte datum narození, nebo pohlaví!
 Ukázka:


Instalování podpory pro běh programu

Na každé stanici, kde chcete program využívat:
  • Spusťte z www stránky dodavatele stažený a dekomprimovaný instalační program "Podpora Vfp8 - Data Protect_Setup_v###.Exe" (###=aktuální verze)
  • Dále postupujte podle jeho pokynů na obrazovce
  • Instalační program "Podpora Vfp8 - Data Protect_Setup_v###.Exe" :
    • Nainstaluje do OS Windows stanice run-time knihovny Visual FoxPro 8
    • Doinstaluje do systémového adresáře OS Windowsknihovnu dll pro šifrování dat
    • Doinstaluje do systémového adresáře OS Windowsknihovny dll pro komprimaci dat
    • Zaregistruje do OS Windows systémové DSN datové zdroje ODBC "Uir-User" pro přístup k datům MS SQL serveru (nebo k MSDE)
  • V "Nástrojích pro správu", v sekci "Datové zdroje (ODBC)":
    • Přidejte nové "Systémové DSN" typu "SQL server" a nakonfigurujte je
  • Pokud ještě nemáte nainstalován program SocM, nainstalujte jej
  • Ověřte správné spuštění programu Socm
Důležitá upozornění:
  • ODBC driver "Uir-User" je registrován ve Windows pouze pro nouzové využití, pokud nebudete moci či chtít využít ODBC driver z SQL serveru (MSDE), kde je instalována databáze "ÚIR-ADR" - Územně identifikační registr adres
  • Je možné, že Vás instalační program při svém běhu vyzve k restartová Windows a pak instalaci dokončí, například
    • když na dané stanici bude potřebovat doinstalovat MS Instaler "MSI engine 2.0"
    • ksyž na dané stanici bude potřebovat doinstalovat jinou standardní komponentu, která ve Windows stanice není
  • Výše uvedené také vysvětluje, proč je instalační program "Podpora Vfp8 - Data Protect_Setup_v###.Exe" tak velký (zhruba 14MB) - obsahuje všechny potřebné komponenty k instalaci do Windows 98 a všech vyšší verzí!


Konfigurace ODBC driveru

Postup nastavení ODBC (obrazovky se mohou lišit dle typu Windows na dané stanici):

Doporučujeme ke konfigurace přizvat Vašeho správce sítě (případně správce databáze na SQL serveru)

1. V nástrojích vyberte "Správce zdrojů (ODBC) - Systémové DSN":

2. zvolte "Přidat" :

2. Vyberte SQL server a zvolte zvolte "Dokončit":

3a. Zadejte název zdroje dat, který používá program Socm
(viz položka "Uir_Adr_Sql_ODBC=..." v souboru "SocM\Ini\Uir_Ini.Ini")
při žádosti o připojení ke zdroji dat, například "UIR_Pokusny".
  • Název zdroje dat se zobrazí v dialogovém okně Správce zdrojů dat ODBC
3b. Vyplňte název serveru SQL Server v síti.
  • Vyberete-li název serveru ze seznamu, není třeba dále zadávat konfiguraci
  • Pokud není server s daty zobrazen, pravděpodobně není stanice v síti, kde se nachází
  • Používáte-li stejný počítač jako SQL Server, lze zadat do pole Server text "(local)"
  • Chcete-li zadat pojmenovanou instanci serveru SQL Server, použijte název serveru ve tvaru "NázevServeru\NázevInstance"
  • Pokud k připojení k serveru SQL Server postačí informace uvedené na této obrazovce, můžete klepnout na tlačítko "Dokončit"
  • Pokud ne, stiskněte v průvodci "Další" a doplňte všechny potřebné údaje, které průvodce dále vyžaduje
Nepovedlo se:
  • Zkuste nápovědu v průvodci
  • Přizvěte správce SQL serveru - ten by měl znát všechny potřebné informace o databázi
  • Snad pomůže telefonická Krapóza - zkuste Krabičku poslední záchrany
Již zde následuje jen ukázka další možné obrazovky průvodce


Aktualizace dat v ÚIR-ADR

Program SocM při svém startu detekuje verzi a datum dat v ÚIR-ADR a pokud jsou data stará, oznámí tuto skutečnost uživateli:

Program sice bude pracovat, ale není zaručeno, že budou dohledávány adresy osob správně, případně některá adresní místa nebudou nalezena.

Doporučujeme co nejdříve data v databázi ÚIR-ADR na MS Serveru (nebo v MSDE) aktualizovat ze změnových souborů z webové stránky MPSV ČR.
Aktualizaci může provést Administrátor databáze ÚIR-ADR (například programem "Padr_sql.exe", který je součástí instalačního CD ÚIR-ADR)

Verzi a datum dat v ÚIR-Adr je možno také zjistit přímo z programu:
Spuštění: Hlavní nabídka - Informace - Systémové údaje - Data v ÚIR-ADR


Nabídka - Úprava vzorů

Při úpravě vzoru máte k dispozici speciální nabídku, pomocí které můžete například:

Vložit vzor makra:

Upravovat typ písma:

Používat standardní postupy kopírování dat ve Windows:

,případně vkládat i jiné formátovací sekvence.

Nejlepší postup je jednotlivé volby vyzkoušet na zkušebním vzoru!


Priorita přístupu

Každý, kdo se přihlásí do programu, má v číselníku hesel stanovena svá přístupová práva, která může být:
  • "1" - pouze prohlížení dat
  • "2" - jako 1, ale má povolen i tisk
  • "3" - standardní přístup
  • "4" - jako 3, ale navíc přístup k vybraným speciálním akcím dle seznamu akcí
  • "5" - administrátorský přístup ke konfiguraci programu

Prioritu v číselníku hesel může upravovat pouze administrátor programu, protože ten má prioritu 5.


Priorita přístupu "4" - Seznam akcí

Každý, kdo se přihlásí do programu s prioritou 4, má oproti prioritě 3 přístup následujícím akcím:
  • Úprava 'parametrů' uživatele programu
  • Úpravy uživatelských číselníků
  • Úpravy vzorů tisků
  • Vytváření dotazů do SSP a na ÚP a zpracování odpovědí
  • Vytváření výstupů plateb


Nejčastější problémy

V jednotlivých kapitolách jsou popsány nejčastější problémy, se kterými si uživatelé většinou neumí poradit.

Vyberte si v seznamu níže popis, který vystihuje Váš problém.

Pokud máte jiný problém, kontaktujte naši firmu , rádi Vám pomůžeme.

Navíc pokud nebude Váš dotaz ojedinělý, zahrneme jej i s odpovědí do nové verze této elektronické nápovědy.


Obsluha Registru obyvatel

Chcete si přečíst základní informace o registru obyvatel?

Chcete si přečíst popis hlavních funkcí modulu?

1. Spuštění modulu

Priorita přístupu: 5
Spuštění: Hlavní nabídka - Akce - Registr obyvatel

2. Postup importu dat z Evidence obyvatel MÚ
  • Zkontrolujte, zda máte k dispozici z Evidence obyvatel MÚ VŠECHNY POTŘEBNÉ SOUBORY k provedení importu dat v kódování Windows 1250 !
  • V nabídce "Import - Dat z EO MÚ (soubory *.unl)":

    postupujte odspodu nahoru:
    • Upravte konfiguraci importu (volba "Konfigurace importu")
    • Proveďte inicializaci importu (volba "Inicializace importu") a vytiskněte si opis jak opis chyb, tak i opis varování
  • Naimportujte data (volba "Importovat kompletní data" - již by měla být volba přístupná)
  • Při importu si můžete vytisknout přehled chyb a varování (i jen některou část)
  • Po závěrečném potvrzení a provedení importu je již na obrazovce uveden počet osob v EO, například:
3. Chybové výpisy

Vytištěné přehledy chyb použijte k tomu, abyste mohli v EO ČR reklamovat chybné údaje.

4. Aktualizace dodacích pošt ČR
  • Doporučujeme ihned po importu dat aktualizovat Číselník dodacích pošt ČR (volba "Aktualizace - Číselníku dodacích pošt - z ÚIR-ADR")
  • Aktualizaci Číselníku dodacích pošt ČR doporučujeme spouštět vždy, když provedete aktualizaci dat v ÚIR-ADR
  • Do číselníku jsou vybírány jen dodací pošty, které mají vazbu alespoň na jedno adresní místo
  • Sql dotaz pro výběr dat je složitější, akce aktualizace může trvat desítky sekund
5. Další důležité informace

Pokud používáte programy pro přechodné období, doporučujeme po importu dat z EO:
  • Provést export registru obyvatel (jen licencovaný program SocM)
    • Volba "Export - Do Win_Regi (pro přechodné verze programu) - Registru obyvatel"
    • Vyexportovaná data naimportovat ve "Win_Regi\" programem Registr.exe (uživatelský soubor, kódování 1250)
    • Vyexportovaný soubor po importu do "Win_Regi\" SMAZAT
  • Provést export Číselníku dodacích pošt ČR (jen licencovaný program SocM)
    • Volba "Export - Do Win_Regi (pro přechodné verze programu) - Číselníku dodacích pošt"
    • Vyexportovaný soubor WCisPost.Dbf nakopírovat do "Win_Regi\", spustit Registr.exe s provedením indexace
    • Tato akce prování současně i aktualizaci Číselníku dodacích pošt ČR pro program SocM
Za zmínku ještě stojí volba "Ukaž", která snad nepotřebuje komentář, vyzkoušejte si ji.

Konec informací o Obsluze registru obyvatel